I have a Dart/Flutter project with dependencies
graphql: '^2.1.1-beta.5' and
flutter_bloc: ^3.0.0, which require different versions of
rxdart that cause version solving to fail. My temporary fix is to downgrade
^2.1.1, but is there a way to use the latest version of
dependencies: graphql: '^2.1.1-beta.5' flutter_bloc: ^3.0.0
Because flutter_bloc >=3.0.0 depends on bloc ^3.0.0 which depends on rxdart ^0.23.0, flutter_bloc >=3.0.0 requires rxdart ^0.23.0. And because graphql 2.1.1-beta.5 depends on rxdart ^0.22.0 and no versions of graphql match >2.1.1-beta.5 <3.0.0, flutter_bloc >=3.0.0 is incompatible with graphql ^2.1.1-beta.5. So, because com.myapp depends on both graphql ^2.1.1-beta.5 and flutter_bloc ^3.0.0, version solving failed.